BETA

22nd September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [22/09/18 11:59 AM] with 'Major Outage'

Issue has been resolved at [22/09/18 12:00 PM]