BETA

22nd September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [22/09/18 12:13 AM] with 'Partial Outage'

Issue has been resolved at [22/09/18 12:15 AM]