BETA

21st September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/09/18 04:08 PM] with 'Partial Outage'

Issue has been resolved at [21/09/18 04:10 PM]