BETA

21st September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/09/18 01:16 PM] with 'Partial Outage'

Issue has been resolved at [21/09/18 01:20 PM]