BETA

21st September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/09/18 11:42 AM] with 'Major Outage'

Issue has been resolved at [21/09/18 11:44 AM]