BETA Singapore cluster       Mumbai cluster

23rd June 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/06/19 04:51 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/06/19 04:55 AM]