BETA Singapore cluster       Mumbai cluster

23rd June 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/06/19 04:50 AM] with 'Partial Outage'

Issue has been resolved at [23/06/19 04:55 AM]