BETA Singapore cluster       Mumbai cluster

23rd June 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [23/06/19 04:49 AM] with 'Major Outage'

Issue has been resolved at [23/06/19 04:55 AM]