BETA

21st September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [21/09/18 10:08 AM] with 'Partial Outage'

Issue has been resolved at [21/09/18 10:10 AM]