BETA Singapore cluster       Mumbai cluster

23rd June 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [23/06/19 04:49 AM] with 'Partial Outage'

Issue has been resolved at [23/06/19 04:54 AM]