BETA

27th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/04/17 10:55 AM] with 'Partial Outage'

Issue has been resolved at [27/04/17 10:56 AM]