BETA

20th September 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [20/09/18 02:51 PM] with 'Major Outage'

Issue has been resolved at [20/09/18 02:52 PM]