BETA

27th April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/04/17 10:39 AM] with 'Partial Outage'

Issue has been resolved at [27/04/17 10:40 AM]