BETA

20th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/09/18 01:22 PM] with 'Partial Outage'

Issue has been resolved at [20/09/18 01:28 PM]