BETA

20th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [20/09/18 01:10 PM] with 'Major Outage'

Issue has been resolved at [20/09/18 01:30 PM]