BETA

27th April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [27/04/17 12:06 AM] with 'Partial Outage'

Issue has been resolved at [27/04/17 12:07 AM]