BETA

20th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [20/09/18 07:13 AM] with 'Major Outage'

Issue has been resolved at [20/09/18 07:18 AM]