BETA

19th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [19/09/18 10:05 PM] with 'Major Outage'

Issue has been resolved at [19/09/18 10:28 PM]