BETA

25th April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [25/04/17 09:20 AM] with 'Partial Outage'

Issue has been resolved at [25/04/17 09:21 AM]