BETA

19th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [19/09/18 02:01 PM] with 'Major Outage'

Issue has been resolved at [19/09/18 02:02 PM]