BETA

18th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [18/09/18 03:04 PM] with 'Major Outage'

Issue has been resolved at [18/09/18 03:07 PM]