BETA

18th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [18/09/18 02:39 PM] with 'Partial Outage'

Issue has been resolved at [18/09/18 02:41 PM]