BETA

18th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [18/09/18 02:13 PM] with 'Partial Outage'

Issue has been resolved at [18/09/18 02:14 PM]