BETA

23rd April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [23/04/17 01:12 PM] with 'Partial Outage'

Issue has been resolved at [23/04/17 01:13 PM]