BETA

20th June 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [20/06/19 07:40 PM] with 'Partial Outage'

Issue has been resolved at [20/06/19 07:41 PM]