BETA

22nd April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [22/04/17 08:10 PM] with 'Partial Outage'

Issue has been resolved at [22/04/17 08:11 PM]