BETA

17th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [17/09/18 05:44 PM] with 'Partial Outage'

Issue has been resolved at [17/09/18 05:45 PM]