BETA

17th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [17/09/18 01:22 PM] with 'Major Outage'

Issue has been resolved at [17/09/18 01:23 PM]