BETA

17th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [17/09/18 01:10 PM] with 'Partial Outage'

Issue has been resolved at [17/09/18 01:14 PM]