BETA

17th September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [17/09/18 10:57 AM] with 'Partial Outage'

Issue has been resolved at [17/09/18 11:32 AM]