BETA

16th September 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [16/09/18 10:37 PM] with 'Major Outage'

Issue has been resolved at [16/09/18 11:32 PM]