BETA

16th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/09/18 02:59 PM] with 'Partial Outage'

Issue has been resolved at [16/09/18 03:00 PM]