BETA

16th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [16/09/18 10:58 AM] with 'Major Outage'

Issue has been resolved at [16/09/18 11:00 AM]