BETA

16th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/09/18 05:10 AM] with 'Partial Outage'

Issue has been resolved at [16/09/18 07:58 AM]