BETA

18th April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [18/04/17 07:11 PM] with 'Partial Outage'

Issue has been resolved at [18/04/17 07:12 PM]