BETA

16th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/09/18 03:14 AM] with 'Partial Outage'

Issue has been resolved at [16/09/18 03:15 AM]