BETA

16th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [16/09/18 12:10 AM] with 'Partial Outage'

Issue has been resolved at [16/09/18 12:12 AM]