BETA

18th July 2016

Incoming SMS Issue observed for Incoming SMS across India

Identified at [18/07/16 12:14 AM] with 'Major Outage'

Issue has been resolved at [18/07/16 12:15 AM]