BETA

15th September 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [15/09/18 01:03 PM] with 'Major Outage'

Issue has been resolved at [15/09/18 01:05 PM]