BETA

15th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/09/18 12:41 PM] with 'Partial Outage'

Issue has been resolved at [15/09/18 12:42 PM]