BETA

14th September 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [14/09/18 01:39 PM] with 'Partial Outage'

Issue has been resolved at [14/09/18 02:05 PM]