BETA

14th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/09/18 01:26 PM] with 'Major Outage'

Issue has been resolved at [14/09/18 01:29 PM]