BETA

18th April 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [18/04/17 06:44 PM] with 'Major Outage'

Issue has been resolved at [18/04/17 07:10 PM]

RCA: http://status.exotel.in/incident/689