BETA

13th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/09/18 11:45 AM] with 'Major Outage'

Issue has been resolved at [13/09/18 11:46 AM]