BETA

12th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/09/18 01:40 PM] with 'Partial Outage'

Issue has been resolved at [12/09/18 01:41 PM]