BETA

12th September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/09/18 12:41 PM] with 'Partial Outage'

Issue has been resolved at [12/09/18 12:42 PM]