BETA

12th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/09/18 12:40 PM] with 'Major Outage'

Issue has been resolved at [12/09/18 12:43 PM]