BETA

11th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [11/09/18 11:24 AM] with 'Partial Outage'

Issue has been resolved at [11/09/18 11:26 AM]