BETA

9th September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [09/09/18 04:19 AM] with 'Partial Outage'

Issue has been resolved at [09/09/18 04:21 AM]