BETA

8th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [08/09/18 01:51 PM] with 'Major Outage'

Issue has been resolved at [08/09/18 01:52 PM]